Colin Cochrane

Colin Cochrane is a Software Developer based in Victoria, BC specializing in C#, PowerShell, Web Development and DevOps.

IIS 7 Site Won't Start After Upgrading to Vista Service Pack 1

After letting Service Pack 1 install overnight, I logged in to my machine this morning looking forward to exploring some of the new features added to IIS 7.0.  Unfortunately there was a small problem with one of the local web applications that I host from my machine.  Simply put, the application refused to start in IIS, and each attempt to start it resulted in a modal pop-up informing me that the process was in use.  I quick peek at the error log showed the following:

iis1

iis2

iis3

After I quick search I found a KB article over at Microsoft that addressed the problem.  As directed by the article, I popped open the command prompt and ran netstat -ano to get a list of what processes were listing for net traffic on what port.  First entry on the list identified the problem process.

image

(The screencap was taken after the problem was fixed, so the PID is not the same).  I opened up the task manager to find out what process was at fault, and it turned out that Skype was listening for incoming traffic on port 80 for some silly reason.  I closed up Skype and attempted to start the website and lo-and-behold, it worked.  I started Skype again, and everything was working like normal again.

I thought this may be of use to anyone who encounters a similar problem.

Comments (10) -

  • Jason

    3/25/2008 7:28:20 AM | Reply

    This was happening to me way before SP1.  Although unfortunately for me I found this posting while trying to figure out why my IIS 7 installation is hosed after installing SP1 for Vista yesterday. >Frown

  • Leslie C

    4/10/2008 12:23:22 PM | Reply

    Found this post on my first search of vista IIS won't start. This was the exact problem. Thank you for the post.

  • Eliyahu

    5/6/2008 3:31:00 AM | Reply

    It worked for me too. Thank you.

  • Aaron Seet

    5/29/2008 11:12:32 PM | Reply

    This has been a problem with Skype for many years now. Back in the old winXP and IIS 5 days.

  • shoes

    7/22/2011 3:17:34 PM | Reply

    Found this post on my first search of vista IIS won't start. This was the exact problem. Thank you for the post.

  • Real Instagram Followers

    12/12/2015 3:49:19 PM | Reply

    There are some interesting points in time in this article but I don’t know if I see all of them center to heart. There is some validity but I will take hold opinion until I look into it further. Good article , thanks and we want more! Added to FeedBurner as well

  • Real Instagram Followers

    12/12/2015 7:06:27 PM | Reply

    Spot on with this write-up, I truly think this website needs much more consideration. I’ll probably be again to read much more, thanks for that info.

  • Mold Inspection

    1/4/2016 6:49:55 AM | Reply

    very nice post, i certainly love this website, keep on it

  • free mysql database

    1/6/2016 4:34:10 AM | Reply

    WONDERFUL Post.thanks for share..more wait .. …

  • C & R Medical review

    1/13/2016 6:55:06 AM | Reply

    Spot on with this write-up, I truly think this website needs much more consideration. I’ll probably be again to read much more, thanks for that info.

Loading